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SOFTWARE LICENSE AGREEMENT

Thank you for purchasing the Super SEL Controller PC Interface Software for Windows.  Using this software consti-
tutes the user’s acceptance of the terms of the software license agreement so please read this carefully prior to
installing the software.  If you cannot comply with these terms, you may return the unused software to IAI for a full
refund.

Intelligent Actuator, Inc. (“IAI”) grants a nontransferable and nonexclusive right to use the software program 
(“Software) enclosed with this agreement in accordance with the conditions stated below and the purchaser (“User”) 
hereby agrees to the same.

1. Term of Agreement
This agreement becomes effective when the User installs the Software and remains in effect until the User
informs IAI otherwise or until the User terminates the agreement per Article 4 below.

2. Transfer and Use Restrictions
The User can install the Software in a single computer only.  To run the software in more than one computer
requires a separate license agreement.  Unless the User has received the written consent of IAI, the User is not
permitted to transfer or grant the use of the Software or any accompanying material to a third party.  The User
cannot provide this Software to anyone except employees of the User or IAI without the express written consent
of IAI.  The User is not permitted to print or reproduce the Software or any portion thereof except under condi-
tions specifically stated in this agreement.

3. Copying Restrictions
Under the terms of this agreement, the User is not permitted to reproduce any printed material, or any portion
thereof, provided by IAI.  The User is allowed to copy the Software in machine-readable form for backup
purposes only.

4. Terminating the Agreement
If the User violates any provision of this agreement or if for some reason he cannot comply with the terms of this
agreement, IAI has the right to terminate this agreement immediately without any prior notification.  In such
event, the User will destroy the Software and any copies within 10 days of the termination of this agreement and
notify IAI that this action has been taken.

5. Limited Warranty
IAI has the right to modify any portion of the Software specifications without prior notification to the User.  IAI
does not issue any warranties with respect to the Software and the User shall not be entitled to request compen-
sation for any damages that may result from the use of the Software.
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A Word of Caution

� This software is copyrighted by Intelligent Actuator, Inc. ( IAI).
� This software and the accompanying manual may not be used or duplicated in part or in whole without the permis-

sion of Intelligent Actuator, Inc..
� A separate software program must be purchased for each PC in which it is run.
� The software and the manual can only be used under the terms of the licensing agreement.
� We cannot assume responsibility for any damage resulting from the use of this software or the operating manual.
� Please note that the version number printed on the face of this manual does not correspond to the software version

number.
� The contents of this manual may be changed without prior notification.
� This software runs with  Windows 3.1, Windows95 or Windows NT (this software does not contain Windows) and

the manual is written assuming that the user already has a basic understanding of the Windows program.

Microsoft, MS, MS-DOS, Windows, Windows 3.1, Windows95 and WindowsNT are trademarks of the Microsoft Corporation.



Page 3

1. Before Using
1-1 Items Supplied With This Software ............................................................................................................. 4
1-2 What You Will Need .................................................................................................................................... 4
1-3 Software Installation .................................................................................................................................... 4
1-4 Software Startup .......................................................................................................................................... 4
1-5 New Functions and Applicable Controller Types ........................................................................................ 5

2. Menu Window
2-1 Explanation of the Menu .............................................................................................................................. 6
2-2 Explanation of the Commands ..................................................................................................................... 7
2-3 Explanation of the Speed Bar ...................................................................................................................... 9

3. Parameter Window
3-1 Program Parameters ................................................................................................................................... 11
3-2 Serial I/O Parameters ................................................................................................................................. 12

4. Program Run Window .......................................................................................................................................... 13

5. Program Edit Window
5.1 Explanation of Items in the Program Edit Window ................................................................................... 14
5.2 Explanation of the Error Check Window ................................................................................................... 16
5.3 Program Save and Edit Completion ........................................................................................................... 17

6. Program Selection Window
6.1 Program Copy ............................................................................................................................................ 18
6.2 Program Delete .......................................................................................................................................... 19

7. Point Edit Window
7.1 Explanation of Items in the Point Edit Window ........................................................................................ 20
7.2 Point Save and Edit Completion ................................................................................................................ 21

8. Axis Status · Move Window .................................................................................................................................. 22

9. Input/Output Ports · Flag Window ................................................................................................................... 23

10. Global Variable Window ...................................................................................................................................... 24

11. Clear Memory Window ........................................................................................................................................ 25

Supplement
Super SEL PC Interface Software for Windows, Additional Application (converter) ............................................. 26

Table of Contents



Page 4

1.1 Items Supplied With This Software

Please check to make sure that the following items are included in your PC software package.

�  Operating manual
�  3.5-inch floppy disk of the software (2)
�  Standard RS232C cable

1.2 What You Will Need (Operating Requirements)

The following PC and accessories will be necessary to run this software program.

� A PC that runs under Windows and compatible keyboard.
� Enough memory to run Windows.
� A monitor compatible with the PC.
� A VGA graphic board or better.
� Mouse or other pointing device and mouse driver.
� Windows 3.1, Windows95, Windows NT).
� A floppy disk drive unit that runs a 3.5-inch disk with 1.25 or 1.44MB capacity.
� The hard disk should have 2MB or more of free memory space.  (The software is run from the hard disk).
	 An RS232C serial port (25 or 9 pins).

 A printer compatible with the PC.

1.3 Software Installation

This software is run from the hard disk.  In this section, we explain how to install the software.

� Insert floppy disk 1 in the floppy disk drive.
� Execute Setup.EXE in disk 1.
� The installation program will be executed, so simply follow the prompts that appear.
� When the installation program is complete, if you are running Windows 3.1, a group icon called SELWIN is created and

appears on the screen.  Double click on this icon to begin running the software.
If you are using Windows95, or WindowsNT, an item called SELWIN is created in the start menu.  Select this item to
run the software.

1.4 Software Startup

� Turn off the power for the PC and the Super SEL controller, then connect the Super SEL controller to the PC with the
standard RS232C cable that comes with the software.

� Turn the PC and Super SEL controller power back on, then run Windows.
� Run the software.
�When you start the software program, on-line or off-line mode is determined by whether the Super SEL controller and

the PC are connected.  If you connect the controller and the PC after the program has been started, you will be unable
to run it in an on-line mode.

� The communication board selection window will open if you have 2 or more Super SEL controllers connected to the
PC.  Select the port to which the target controller is connected.

� When you are running on-line, a window asking the number of actuator axes you are using will open so insert the
appropriate number of axes.

� The main menu (initial screen) will be displayed.   Select the desired operation, then follow the screen prompts and
input the appropriate data.

1 Before You Begin
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1.5 New Functions and Applicable Controller Types

� Some of the functions in this software are not available with certain controllers.  The chart below indicates the functions
that are available by type of controller.

� The expansion commands are not available with the Super SEL controller Type A/B or the Table Top controller.  The
expansion commands are listed below but please refer to the operating manual that comes with the Super SEL controller
for details.

* Expansion commands
Actuator control designation (SCRV)
Actuator control command (MVPI, MVLI, AXST)
Timer command (GTTM)
Calculation command (TRAN)
Point data operation command (PAXS)
Structured IF command (IFEQ, IFNE, IFGT, IFGE, IFLT, IFLE, ELSE, EDIF, ISEQ, ISNE)
Structured DO command (DWEQ, DWNE, DWGT, DWGE, DWLT, DWLE, LEAV, ITER, EDDO)
External input output command (OPEN, CLOS, READ, WRIT, SCHA)
String command (SCPY, SCMP, SGET, SPUT, STR, STRH, VAL, VALH, SLEN)

� Please refer to the supplement section at the end of this manual for information on data conversion for this software
(Windows version) and the DOS software.

1 Before You Begin
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2 Menu Window

2.1 Explanation of the Menu

After you start the software, the main window appears and you will see a menu bar with 9 items and a speed bar with 23
icons displayed (initial screen:  main menu).

When the program is in off-line mode, some of the menu items and icons will not be displayed.

On-Line Start Screen

Off-Line Start Screen
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File File operations (off-line).

New Create new program · point data file.
Program Open a new program edit window.
Point Open a new point data edit window.

Open Select and open an existing program · point data file.
Save   Ctrl+S Overwrite the file with the same name during program · point data file editing.
Save As   Ctrl+A Save the file under a different name during program · point data file editing.
Load Select an existing program · point data file and load it to the controller.
Print Print the selected program · point data · parameter file.
Exit End the software program.

Edit Auxiliary operations when editing programs · point data.
Cut   Ctrl+X Move the marked lines to the clipboard.
Copy   Ctrl+C Copy the marked lines to the clipboard.
Paste   Ctrl+V Copy the contents of the clipboard to the marked line.
Insert   Ctrl+I Insert one line at the line where the cursor is placed.
Search   Ctrl+F Define and search for a character string.
Search next   Ctrl+N Continue searching for the character string defined above.
Replace   Ctrl+R Search for the defined character string and replace it with a designated character string.
CheckErr   Ctrl+E Check for errors when editing a program.

Parameter Functions related to parameters.  (On-line)
Program Change program parameters.
Point Change point parameters.
Servo Change servo parameters.
Axis Parameters by axis.

Servo Change servo parameters by axis.
Home Change homing parameters by axis.
Motor Change motor parameters by axis.
Gain Change gain parameters by axis.
Device Change device parameters by axis (available only with versions after 3.0).

Serial I/O Serial I/O parameters (displayed only when an SIO board is installed).
Channel 1 Change SIO parameter for channel 1.
Channel 2 Change SIO parameter for channel 2.

High speed input Change high speed input parameters (displayed only when a high speed input board is installed).
Save Save parameters to the disk.
Print Print the parameters.

Program Functions related to the program (on-line).

Run Execute and stop the designated program.  Multiple programs can be run in parallel.

Edit Edit the program.
Write Write the program to the controller while editing.
Copy Copy a program.
Delete Delete a program.
Save Assign a file name to the program and save.
Save All Assign a single file name to all programs in the controller and save.
Print Print out a program.

2 Menu Window

2.2 Explanation of the Commands
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Point Functions related to position data (on-line).

Edit Edit points.
Write Write points to the controller during edit.
GetPoint Read current position of axis at cursor position.
Delete Delete designated range of points.
Save Assign a file name to points during edit and save.
Print Print the points.

Test Functions related to controller operation (on-line).
Servo Perform axis status check and jog movement.
Input Display status of input port.
Output Display status of and change output port.
Flag Display and change flags.
Variable Display global variables (200~399)
Version Display version number.
Clear Delete parameters, programs and points.
Reset Reset the controller.

Setup

Printer Set up the printer.

Window Manage the windows displayed on screen.

Cascade Line up the windows in an angle so they overlap.

Tile Horizontal Arrange the windows horizontally without any overlap.
Tile Vertical Arrange the windows vertically without any overlap.
Arrange icon Line up the icons along the bottom of the screen.

Help

About Displays the software copyright and version number.

2 Menu Window
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2 Menu Window

2.3 Explanation of the Speed Bar

Create a new program file.
Same function as File → New → Program.

Create a new point file.
Same function as File → New → Point.

Edit a file.
Same function as File → Open.

Load to controller.
Same function as File → Load.

Save edits to the file.
Same function as File → Save or File → SaveAs.

Write edits to the controller.
Same function as Program → Write or Point → Write.

Print file.
Same function as File → Print.

Cut (move) selected range to the clipboard.
Same function as Edit → Cut.

Copy selected range to the clipboard.
Same function as Edit → Copy.

Paste the contents of the clipboard.
Same function as Edit → Paste.

Search for character string.
Same function as Edit → Search.

Perform next search for designated character string.
Same function as Edit → Search Next.
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Replace designated character string with another designated character string.
Same function as Edit → Replace.

Open program run window.
Same function as Program → Run.

Check program
Same function as Edit → CheckErr.

Get current position of axis as point data.
Same function as Point → Get Point.

Operate and display status of axis.
Same function as Test → Servo.

Display input port status.
Same function as Test → Input.

Display output port status.
Same function as Test → Output.

Display flag status.
Same function as Test → Flag.

Display content of global variable.
Same function as Test → Variable.

Reset controller.
Same function as Test → Reset.

2 Menu Window
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3 Parameter Window

3.1 Program Parameters

� From the menu, select Parameter → Program.

� The program parameter window opens.
Select the appropriate parameter and correct the value.
The values for number of programs, number of tasks, number of steps are semi-transparent.  These are intrinsic to the
controller and therefore cannot be changed.

� After entering corrections, click OK and the program parameter write window opens.  Click Yes to write the changes
to the controller.  Click No to end the operation without saving changes.
It is necessary to reset the controller to make the parameter changes effective.

Above, we explained the program parameters but the operation is the same for other parameters with the exception of
those for serial I/O.
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3 Parameter Window

3.2 Serial I/O Parameters

� From the menu, select Parameter → Serial I/O → Channel 1 or Channel 2.

� The Serial I/O Parameter window opens.
Select the appropriate parameter, mark the correct value for the communication target, then set the TimeOut.

� After entering corrections, click OK and the serial I/O parameter write window opens.  Click Yes to write the
changes to the controller.  Click Cancel to end the operation without saving changes.
It is necessary to reset the controller to make the parameter changes effective.
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4 Program Run Window

� From the menu, select Program → Run.

� The task status window is displayed and has the following items.

Program Displays program no. and number of steps.  Select program to execute from this column.

No. Displays the task no.

Sts Displays the program status.

L Displays the task level.

Pg Displays the program no. currently running.

E ~ Comment Displays the step currently being executed.  Each of these items is the same as in program edit.

� The following buttons appear at the bottom of this screen.

Run Runs the program selected in the program list.

Stop Stops the program selected in the task list.

AllStop Stops all programs currently running.

Local Opens the local variable window for the program selected from the task list that is currently running.

Cancel Closes the window.  Even if you close the window, the program currently running does not stop.
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5 Program Edit Window

5.1 Explanation of Items in Program Edit Window

� From the menu, select Program → Edit.

� The program selection window is displayed.  Select the program you wish to edit, then click OK.

� The controller program window opens and has the following items.

Step Displays the program line number.  No input is required.

E Specify expansion condition using A or O.  A = And,  O = Or.

N Designate the reverse input condition.  Specifying N reverses the condition.  N = Not

Cnd Designate the input condition.  Designate the input/output port and flag.  Range is 1~999.

Cmnd Designate the command.  Input by typing the command directly from the keyboard or double-
click to call up the program command list and make a selection.  If you key one or more
characters of the desired command before double-clicking on the Cmnd box, the cursor will be
at the corresponding command in the program command list.  Hit Enter or double-click on the
desired command to enter the command.

Operand 1, 2 Given below is the data that can be entered in this column.

Numerical values
Numbers such as input/output · flag · variable no., column no., tag no., subroutine no., axis
no., position no., program no., task level, source no., channel no., etc. are entered directly.
Variables
For items where numeric data is designated,  numbers can be designated indirectly by entering
a variable no.  For example, if 10 is in variable 1, designating *1 is the same as designating 10.
Axis pattern
Specify the axis using binary notation.  0 = not selected, 1 = selected.
Character string
Data enclosed in ‘    ’  marks is considered a character string.

Pst Indicates the output port or flag that is turned ON when the conditions of each command are
met.  The number range that can be entered is 300~999.

Comment You can add program notes up to 18 characters here.  This is useful in creating a program that
is easy to read.  This column can be used by itself or left blank as required.

� Place the cursor at the comment column, then press Enter to move to the next line.
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5 Program Edit Window

Note:  When you click on the command line, a description and name of the command appears at the bottom of the screen.
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5 Program Edit Window

5.2 Explanation of the Error Check Window

� From the menu, select Edit → CheckErr.

� When you run the program error check, an error list will be displayed if there are any errors in the program.  The
error list shows the line number and column number where the error is located.  Double-clicking on an error item
moves the cursor to the corresponding position in the program display.
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5 Program Edit Window

5.3 Program Save and Edit Completion

� File → Save
Save the program to a file.
Note:  If no name is assigned to the file, the operation will be the same as for ��following.

� File → Save As
Assign a name to the program and save.

� Program → Write
Save the program to the controller.  This is available only when editing a program.
Note:  If there is an error in the program, the error window will be displayed.

� Closing the program edit window.
When you close the program after editing, the following message appears.

Yes Program is changed and operation ends.  The program is written to the place where it was stored.

No The changes are cancelled and operation ends.

Cancel Program close is cancelled and editing continues.

Note:  When saving a program, the program error check is executed automatically.  If there is an error, the save operation
will end.
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6 Program Selection Window

6.1 Program Copy

� From the menu, select Program → Copy.

� The program copy window opens.  Double-click on the program number you wish to copy and this number appears
in the source program number box in the information dialog box.

� Double-click on the program number you wish to copy the program to and this number will appear in the dest.
program no. in the information dialog box.  Select one of the following options by clicking on that button.

Append Copy the source program at the end of the destination program.

Overwrite Copy the source program to the destination program after deleting the existing program.

Cancel Cancel the operation.
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6 Program Selection Window

6.2 Program Delete

� From the menu, select Program → Delete.

� The program delete window is displayed.  Click on the program number you wish to delete and this number will
appear in the delete program no. box in the information dialog box.

� Click on the cancel button to delete the program.
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7 Point Edit Window

7.1 Explanation of the Items in the Point Edit Window

� From the menu select Point Edit.

� The point data selection window appears.  Select the range of point numbers to be edited and click OK.

� The controller point data window appears and has the following items.

No. This is the point number.  Data input is not required.

ACC Specifies acceleration.  The setting range is from 0.01 to the maximum acceleration in the
servo parameter.

Vel Specifies velocity.  The setting range is from 1 to the maximum velocity in the servo param-
eter.

Axis 1~8 Specify the position of each axis.  The setting range is -9999.999~9999.999.

� Place the cursor at the last axis and press enter to move to the next line.



Page 21

7.2 Point Save and Edit Completion

� File → Save
Save the point to a file.
Note:  If no name is assigned to the file, the operation will be the same as for ��following.

� File → Save As
Assign a file name to the point and save.

� Point → Write
Save the points to the controller.  This is available only when editing a program.

� Closing the point edit window.
When you close the point edit window after editing, the following message appears.

7 Point Edit Window

Yes Point is changed and operation ends.  The point is written to the place where it was stored.

No The changes are cancelled and operation ends.

Cancel Point close is cancelled and editing continues.
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8 Axis Status · Move Window

� From the menu, select Test → Servo.

� The axis status · move window is displayed.
The axis selection switch, axis no., current position and status are displayed.  From the menu, select Point → Edit to open the
point edit window (controller point data).  Select Point → GetPoint to obtain the current position of the axis.

Click on the forward/backward switch to move the axis or axes that was designated with the axis status selection switch.

Home The designated axis homes.

Forward/Backward Start axis jog movement.  The axis moves while this switch is pressed.

Servo ON/OFF Turn the servo ON and OFF.

Acceleration Set the acceleration for axis movement.

Velocity Set the velocity for axis movement.
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9 Input/Output Port · Flag Window

� From the menu, select Test →  Input, Output, or Flag.

� The input, output and flag windows are displayed.    These windows display the current value of the input port, output
port and flag.  For output port and flag, you can force the status ON/OFF by double clicking on the desired output port or
flag.
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10 Global Variable Window

� From the menu, select Test → Variable.

� The global variable window opens and the value for the current global variable is displayed.
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11 Clear Memory Window

� From the menu, select Test → Clear.

� The clear memory window opens.
Mark the item to initialize from parameter, program or point and click OK.  If parameter is selected, all parameters,
programs and points are deleted.  After resetting the controller, default parameters are used by the controller.

Note:  Be certain that you wish to clear controller memory as there is no confirmation after you click the OK button.



Page 26

Super SEL Controller PC Interface Software Windows Version, Additional Applications

Introduction

Those who have been using the Super SEL Controller PC Interface Software DOS version may find some inconvenience in
using the Windows version since the data formats are not compatible.  Because of this, we have prepared a data conversion
software (CONV.EXE) for your use.

Please be careful to note that this additional software (CONV.EXE) is designed to run in DOS, not Windows.  If you intend
to use this converter all the time, you can run the file from any location if you set up a path to the directory where the
(CONV.EXE) file resides.  To set up the path, add the string given below to the (AUTOEXEC.BAT) file in the root directory.

PATH=A:\SEL32WIN;%PATH%
In this example, the file resides in the root directory called SEL32WIN located in the A drive.  (If your SEL32WIN
program is stored in a different drive, change the name accordingly).

Data Converter - How to Use CONV.EXE

CONV.EXE is a program that is run from DOS and allows conversion of IAI data files from DOS format to the Windows
format and vice versa.  Exit Windows or run the program from the DOS window.

To use, enter the following at the command line,
CONV.EXE    file name.extension

During this operation the type of data is distinguished by the extension so please make sure to include the extension when
entering the file name.  The data type and extension are as follows.

Type of file DOS Windows
Parameter file *.PAR *.PRM
Program file *.F32 *.PRG
Collective save program file *.X32 *.ALL
Point file *.P32 *.PNT

The name of the converted file will be the original file with an extension corresponding to the new data type. If that file name
is the same as another existing file, the following prompt will appear.

...FileName.EXT exists, Overwrite OK [Y:  yes] ?

If it is okay to overwrite the existing file, press Y.  If you press any other key, the program will end without converting the file
or it will move on to the next file to be converted.

You can use the wild cards * and ? to designate the file.
* =  any character string and ? = any character.

Supplement
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Examples:

CONV.EXE Data1.F32
Converts the file named Data1.F32 in DOS to a file named Data1.PRG in Windows.

CONV.EXE*.P32
Converts all DOS point files in the current directory to Windows files of the same name but with the extension .PNT.

CONV.EXE D*.X32
Converts all DOS collective program files in the current directory that begin with the letter D to Windows collective
program files of the same name but with the extension .ALL.

CONV.EXE Data?.PAR
Converts all DOS program files in the current directory with the name of Data + 1 character (Data1, Data2, etc.) to
Windows files of the same name but with the extension .PRM.

CONV.EXE Data1.F32 Data1.PNT Data1.PAR
Converts Data1.F32 and Data1.PAR from a DOS to a Windows file and Data1.PNT from a Windows to a DOS file.

CONV.EXE*.*
Converts all DOS files in the current directory to Windows files with the same name (the extension is converted).

Supplement
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